Question Details

Answered
LINE OAuth redirect on safari in IPHONE to LINE APP Failing

I'm trying to integrate LINE OAuth in my web app. It has been a successful implementation. There is one case when the system fails: trying to authenticate on IOS Mobile device in safari browser!

There are two possibilities when a user tries to sign up on an IOS mobile device: a) user has LINE app installed, or b) LINE app is not installed.

If it is case b), there is no issue.

In case a), there are again two possibilities: i) User is logged on access.line.me (auth site for LINE) in safari browser, or ii) User is not logged in

In case i), there is no issue.

In case ii), when a decides to authenticate using LINE, we redirect the user to access.line.me with proper config and redirect url, the IOS device then launches the LINE app for authentication, and redirect url is opened in a new tab. Issue here is that we are not able to get the control in to the app, and the pop up launched after authentication stays as a blank screen on the browser.

One solution thought was if we could stop safari/IOS device from launching the app and continuing the authenticatio in the browser itself, it would work. But, not sure if we can prevent app from being launched (if there is, can someone help)?

Or, is there any other way this issue could be solved?

0
Profile picture
Himanshu Budhia

Answers

4
Profile picture
bottsjw-War Phoenix
Posted: 3 months ago

Just to be sure, is this issue in iOS or is it the new iPadOS? The new iPadOS no longer behaves like iOS and we’ve seen similar issues. iPadOS more like the behavior in MacOS which is less than ideal for authentication.  

Profile picture
Himanshu Budhia
Posted: 3 months ago
Edited: 3 months ago

Hi, this issue is coming on a regular iPhone using safari.

Profile picture
João Rosário
Posted: 2 months ago

Any updates on this issue? facing a similar problem

Profile picture
Himanshu Budhia
Posted: 1 months ago

This issue was solved using cookies. Adding cookies on redirect to app and reading on app load helped solve this issue.

Are you sure? question.vm