Question Details

Domain=LineSDKServerErrorDomain Code=0 "Authentication API Error"

LineSDKLogin.sharedInstance().start() -> allow in LINE Applicaiton -> Error

Error Domain=LineSDKServerErrorDomain Code=0 "Authentication API Error" UserInfo={NSLocalizedDescription=Authentication API Error, NSUnderlyingError=0x28217de60 {Error Domain=NSURLErrorDomain Code=-1005 "The network connection was lost." UserInfo={NSUnderlyingError=0x282156b20 {Error Domain=kCFErrorDomainCFNetwork Code=-1005 "(null)" UserInfo={NSErrorPeerAddressKey=<CFData 0x280c17020 [0x1c14ed5e0]>{length = 16, capacity = 16, bytes = 0x100201bbab66f02d0000000000000000}, _kCFStreamErrorCodeKey=-4, _kCFStreamErrorDomainKey=4}}, NSErrorFailingURLStringKey=, NSErrorFailingURLKey=, _kCFStreamErrorDomainKey=4, _kCFStreamErrorCodeKey=-4, NSLocalizedDescription=The network connection was lost.}}}

How to fixed it LINE

Profile picture
PingChay (ฉาย)


Profile picture
Posted: 4 months ago
Edited: 4 months ago

In 'LineSDK', '~> 5.0'

You must change [[LineSDKLogin sharedInstance] startLogin]; to [[LineSDKLogin sharedInstance] startLoginWithPermissions:@[@"profile", @"openid"]];.

Profile picture
Tran Trong Hien
Posted: 1 years ago
Edited: 1 years ago

i same you, too? How to fix it? When i authenticate by Line app, sometime Line Server return success, somtime return fail. But, when i authenticate by web app, it is OK.

Profile picture
Yongjae Chuh
Posted: 5 months ago

same error here.

Profile picture
Ming Tim
Posted: 4 months ago
Edited: 4 months ago

use the function" [[LineSDKLogin sharedInstance] startLoginWithPermissions:@[@"profile", @"openid"]]; " the same error exist. sdk 4.1.1(obj-c)

Are you sure? question.vm