Question Details

Answered
Is Line Login v2 deprecated?

I'm testing Line login with sorcery gem for Ruby on Rails app.

Although the commit is not yet merged, there's pull request for LINE login. Internally it uses v2 api. The url of authorization corresponds to the doc.

However, when I tried to login, Line rejected it due to wrong password. I already confirmed the other already-deployed service accept my login. Password is correct.

My smartphone setting is "allow login". I tested https environment and callback url is well configured.

In official LINE DEV twitter account, v1 deprecation was announced, but v2 is not yet. Is Line Login v2 deprecated too? Or Does LINE accept v2.1 API for new project? I've recently created the project.

0
Profile picture
Hiromichi NOMATA

Answers

1
Profile picture
Hiromichi NOMATA
Posted: 1 years ago

Unlike the other providers, It seems line login ignores url parameters. We can input url in development console, but this will cause errors internally. That means you cannot use url like /callback?provider=line which is the default of sorcery. Defining unique url like /callback_line solved the problem.

Are you sure? question.vm