Q&A

Auto-response message in text mode not more working

Pre condition, Condition to reproduce

Bot-Mode > Auto-response messages with keywords (Text only)

Issue / Error Message details

I created many Auto-response messages. Sometimes with image, sometimes with text only, sometimes with both.

Procedure: 1.) I invite this Bot into a group chat. 2.) I trigger my Auto-response message with the set keyword.

Outcome: When I (as the Bot owner / Admin) trigger the Auto-response message, all works fine. The message appears and I can read it. When other users within that chat group trigger the message, it works NOT, if the message contains text only. It works only with images. Also when the message cointans one image and one text block, only the image is shown. So text based Auto-response messages are not send to the users at all (not more, since about 2 weeks).

Accompanying respective source code

No source code, only Bot mode.

Resolution Tried

  • I tried to delete the whole Auto-response message and created it new
  • I tried to use other keywords
  • I mixed the Auto-response message type with image and text

Reference information (Version / Platform/ environment)

The problem occurs at every platform: iOS, Android, PC, Mac, iPhone, iPad whatever... text based Auto-response messages are only sent to me (admin) and never to normal users in the chat group.

  • 1
  • 9
  • 551
  • twitter facebook

Thanks Omer, all is activated well: "Group and multi-person chats" -> is set to: "Allow account to join groups and multi-person chats" and also the option "Allow media and files in chat" -> is set to: "Allow".

I never changed there anything. Whatever, I solved this issue by adding images instead of text based messages. I use now "Rich messages" and "Card-based messages". Which has the added benefit that my messages are now much nicer.

I'm sure the system is the problem but none from the Devs will handle that request. Thats really sad.

Vincent

  • 0

@ksyt how is the problem solved? Ijust showed him the way to find the option. But this doesnt solve the problem.

I tried everything, and have still same problem. Even if I change it to group and multipeople chat.

  • 1

(solved)

  • 0

@Joshivince of course, you just go to your official account manager (manager.line.biz) then click on your account, click right top "settings". On "Accounts Settings" you can find down the topic "Toogle features". There you can choose "Group and multi-person chats".

  • 0

Nice that you found the option Omer, but can you please say me where to find it?

  • 0

Hi, does anyone have a solution for this problem yet?

@ksyt I have same problem like Joshivince, but I also enabled "allow bot join groups". I also disabled it and tried it out, and enabled it again, but no change.

Problem still exist

  • 0

Hey @ksyt, thanks for your reply. Can you say me where you modified this option? I am acting within https://manager.line.biz/ to configure my bot - you also?

Thanks in advance, Vincent

  • 0

Do you enable Allow bot to join group chats feature in developer console? My bot works as usual when I tested.

  • 0

have exactly same problem, since 3-4 weeks now, cant find any solution.

  • 0

関連する質問

    関連する質問はありません

本当によろしいですか? question.vm