Q&A

line/liffを利用するnodejsのバージョンを教えてください。

前提・実現したいこと

チャンネルアクセストークン作成

発生している問題・エラーメッセージ

[ec2-user@ip-172-31-46-145 ~]$ sudo yarn add @line/liff yarn add v1.22.11 info No lockfile found. [1/4] Resolving packages... [2/4] Fetching packages... error @line/bot-sdk@7.4.0: The engine "node" is incompatible with this module. Expected version ">=10". Got "6.17.1" error Found incompatible module. info Visit https://yarnpkg.com/en/docs/cli/add for documentation about this command.

該当のソースコード

なし

試したこと

LINEミニアプリ開発

補足情報(FW/ツールのバージョンなど)

  • 0
  • 2
  • 1162
  • twitter facebook

https://developers.line.biz/ja/docs/liff/overview/ LIFF の推奨環境に node はないようです

  • 0

Expected version ">=10". Got "6.17.1"

とあるので、まずは10以上にしてみると動くのではないでしょうか...?

  • 0
Are you sure? question.vm