Webhook url does not receive any post

Hi, My line@bot was working normally before. but now, LINE server will not notify webhook url when line@ receiving a message.(no log about request from LINE server.)

I found that if you modify the webhook url to a new domain, the new domain can receive webhook notifications.

Why can't the original domain receive notifications from webhook? Is my previous domain blocked by the LINE Corporation?

P.S. My webhook endpoint not via NGROK web service.

kind regards.

  • 0
  • 11
  • 2646
  • twitter facebook


  • 0



經我們與相關部門確認,目前已將TWCA新的Root Certificate加入SSL憑證列表中,煩請您再次確認是否已可供您正常使用。

**LINE官方客服回覆囉~ 可以換回原本的中繼憑證使用了~

  • 1

好的 感謝你

  • 0

樓主你好 這部份我有與TWCA聯繫, 他們是說可能是部分網路服務是使用舊的根憑證進行驗證, 可以跟TWCA索取中繼憑證, 不過這部份不太清楚如何設定, 你可以向TWCA索取設定看看。

也已向LINE客服說明需要更新根憑證的部分, 不過客服還沒回信給我。


  • 1

目前仍無解 😭 😭

  • 0


  • 1

I'm using TWCA certificate and cannot receive request, too. It worked by using ngrok, too.

  • 1

I use curl to post previous and new endpoint, both of the domain can receive request.

I found that the domains that cannot receive LINE server notifications are TWCA certificate.

Is TWCA certificate banned?

  • 1


Trying to send request using curl to both previous and new endpoint, and comparing the responses will help you a lot.

curl -v -X POST https://your.domain/path/to/endpoint
  • 1

Thank you for your reply.

My SSL certification expiry date is 2021/7.

I tried to set new webhook url to receive LINE server notifications. then new webhook url post the notifications to previous domain. then if I ignore signature value that the bot will work.

But if I set webhook url to previous domain. webhook url does not receive any post.

  • 0

Is your SSL certification for previous domain expired? I recommend to check whether you can access to your previous endpoint with Postman, curl or something like that.

  • 1
Are you sure? question.vm